Excel Essentials
Workbook vs. Worksheet

A “workbook” is an excel file. It can contain multiple worksheets.

A worksheet is what holds the actual data and is what you’ll mainly be working
in. There can be multiple worksheets in one workbook.

Create a new Workbook
File Menu > New. If you get the Project Gallery, choose “Excel Workbook”.

Workspace Overview
Menus are at top. If there’s a shortcut for a particular
command it’s displayed next to command in menu.
Toolbars‐ if you want to add or remove different
toolbars you can do so under the view menu.
Use the View menu to get your “toolbox” – this contains
various control palettes for formatting, formula‐
building, adding objects, etc. Choosing one of these from
the View will make a separate toolbox control window
pop up, usually to the right of your worksheet.
Down at the bottom you will see your worksheet tabs‐ click on the tabs or use the arrows to the left to
switch between the different worksheets in your workbook. You can click the “plus” tab to add a new
worksheet. Right click for options to move, copy, etc.
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View Options‐ Under “View” Menu

The default view is called “Page Layout” and it enables you to see a
print preview of your document and work on it at the same time‐ you
see margins, headers, page breaks, etc.

Your other option is “Normal” view, which is a more traditional
spreadsheet view. It’s a better choice if you have a lot of data and don’t
want to see gaps between pages. You will see page breaks as dotted
lines in this view.
Zoom‐ You can zoom in and out, making your data appear smaller or
larger. Use the “zoom” drop‐down menu in the toolbar.

Row, Columns, Cells
Rows go across.
Columns go up and down.
Rows are numbered and columns are lettered.
Cells are all the little boxes that contain the data. You refer to a
cell by its column‐row coordinates, for example, cell “F5”.
Header Row
The first row in your worksheet is your header row. Always enter this row with descriptions of what is to
go in each column‐ name, address, town, zip, etc. This is going to help you later for sorting and mail
merges.

Selecting a cell
To select a cell, make sure you have a regular open cross cursor and click it. It
will get a heavier border around it and the number/letter of its row and
column will darken. That outline is called the “selection cursor” and it means
that whatever you type will go inside the cell you have selected.
You can move this selection cursor by clicking a different cell or by using the
tab key to move between cells.
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Typing into a cell.
When you’re typing in a cell, you’ll see a blinking cursor inside the cell. You can click inside a cell to move
this cursor to a different place in that same cell, for example to fix a typo you just made.
A blinking cursor shows where you are typing, and can be moved within a cell by clicking the mouse.
When you want to move on to a different cell, you can Tab to the next cell or click the mouse elsewhere.
Double click the cell to get back in and type.
Selecting multiple cells
1. Click and hold the mouse on the top left cell of the group you want to select, then, still holding,
drag the mouse to highlight the group of cells you want.
2. When you have them all, let go.
3. You can also click the top left, let go, and hold down the shift key and click the bottom right. This
will select all the cells in between.
To select just a couple un‐connected cells, click one, hold down the control key, and click the next.
To select ALL the cells in a worksheet, click the upper left‐hand diamond, where the rows and
columns meet.
Selecting Rows & Columns
• To select an entire row or an entire column, place the mouse over the column letter or row
number. The cursor will turn to a black arrow. Click and it will select the whole thing.
• Click, hold, and drag to select multiple columns or rows.
• As with the cells, you can click one, hold down shift, and click another to select all the columns or
rows in between the two you click on.
• You can also click, hold down control, and click another to select ones that are not next to each
other.
•
•

Clearing and Deleting
Clearing: removing whatever is inside a cell, column, or row.
Deleting: gets rid of the cell, column, or row itself, and since you can’t have an empty hole in your
spreadsheet the other cells, rows, or columns will move to fill in the space. This is fairly straightforward
with rows and columns, but if you delete cells it will ask how you wan to fill in the space‐ if you want to
shift cells over from above, below, left, right, etc.
To clear the contents of a cell or cells:
1. Select them
2. Hit the delete or backspace key.
•

You can also Right Click > Clear Contents.

To delete a cell or cells:
1. Select them
2. Right Click > Delete.
•

You can also use Edit Menu > Delete. Remember, when you delete cells, the rest of the cells in the
workspace need to shift over to fill in the space.
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Undo
Did you make a mistake? Edit Menu > Undo will undo your last action. Warning: it’s not always available,
sometimes you might be stuck. If this happens you can always close the file without saving. You’ll lose any
changes you made since you last saved, but you won’t be stuck with your mistake.

Right‐Clicking
You can right‐click your mouse at any time for a contextual menu of options
that relate to what you are doing at the time. If you don’t have a two‐button
mouse, you can hold down the control key and click and hold for the same menu.

Resizing Rows and Columns

1. Place the mouse in the area that has the column letters or row numbers, but right on the line
between two rows or columns. The cursor should change to a double arrow.
2. Click, hold, and drag to make the column larger or smaller.
•

If you want the row or column to automatically resize itself to fit any text you have entered, put
the cursor in the same place and just double click. This is called “auto‐fit”.

If you want to apply any of the re‐sizing measures above to multiple rows or columns, select several and
resize or auto‐fit just one. It will apply your changes to all the ones you have selected.
Tip: If a cell has ###### displayed, this means that the data is not fitting in the cell. Resize the column
appropriately.
Hiding
If you want to temporarily hide a row or column, select it and choose Format Menu > Column or Row >
Hide.

Moving Cells, Rows and Columns

1. Select the ones you want to move.
2. Move your cursor to the outer edge of your selection, and the cursor will turn to a hand.
3. Click, hold, and drag to move your cell. If you move it to an occupied cell Excel will ask if you want
to replace the cell’s contents.
• To move a row or a column, you select an entire row or column and drag it, as above. Do this only
if you have a blank place to move it to. If you want to move it to a place in between two rows or
columns that already have data, follow instructions below for cutting & pasting.
To insert a blank row or column, select the row or column below or to the right of where you want your
blank one. Right click > Insert.
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Cutting, Copying and Pasting
Cutting: removes a cell, column or row from its current location.
Copying: makes a copy and holds it in memory, leaving the original where it is.
Pasting: takes what you cut or copied and places it wherever you have your selection cursor.
To cut or copy a cell or group of cells:
1. Select the cells
2. Edit Menu > Cut or Copy.
3. To paste, place the cursor where you want them to go and Edit Menu > Paste.
To cut/copy and paste a whole row or column:
1. Select the entire row or column. Edit Menu > Cut.
2. Select the entire row or column one spot below or to the right of where you want to place your
row or column.
3. Insert Menu > Insert Cut Cells. This will just shift your existing data over instead of overwriting it.
Edit Menu > Paste Special‐ this gives you some other options for pasting your data. You can strip out
formulas and just paste values, you can “transpose” which will switch data from going up and down to
across and vice versa.

Formatting

Select the cells, column, row, etc that you want to make changes to and go to
Format > Cells, or use buttons in formatting toolbar or palette. This is where you can make changes to
how your worksheet looks‐ fonts, colors, borders, etc. It’s also where you specify what KIND of data a cell
contains‐ numbers, text, dates, currency, etc. so that it can format it appropriately.
Number‐ This is where you can specify if cells or columns contain numbers, and if they do, if you want
excel to format those numbers as dates, currency, etc. Once you make this change to a selection, even if
itcontains blank cells, excel will automatically format whatever you type into those cells into the format
you choose.
The number types you’ll use most often are:
Number‐ just a straight number, you can choose how many decimal places you want, and how you want
negative values to display.
Currency‐ same as above but adds a dollar sign.
Date‐ this gives you lots of options as to how you want your dates formatted.
Font‐ Pretty straightforward. Choose a font, size, italic, bold, etc.
Alignment‐ Here you choose where you want your text placed inside the cell. “Orientation” allows you to
make it go diagonal or whatever direction you want. If you select “wrap text” it will cause cells that
contain lots of text to automatically resize the row to display all the text.
Border‐ puts a border inside or outside your selection, or both. You can choose a border color from the
drop‐down menu.
Patterns‐ This lets you add color or shading to your cells.
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Freeze panes/splits
Sometimes you might want to look at two different areas of your spreadsheet at the same time.
One way to do this is with Freeze Panes, which holds the rows or columns of your choice frozen to the
top or left of the window. This is mostly useful for freezing your header row, so you can see column
headings no matter how far down the spreadsheet you scroll. To do this, select the entire row below the
row you want to keep frozen. Window Menu > Freeze Panes. Note: you must be in “normal” view menu.
Adding a Split gives you two sections (or four if you do both horizontal and vertical) that you can scoll
independently of each other. For a horizontal split, select a row. For a vertical split, select a column. For
both, select one cell. Window Menu > Split.

Sorting

Sorting will put the column(s) of your choice into alphabetical or numerical order.
To sort, select all the cells. Data Menu > Sort. This pops up the sort window.
If you have a header row in your worksheet, check off “My list has header row”.
Then choose what column you want the data sorted by in the drop‐down menus.
You can select up to three columns to sort by. Click OK and it will sort for you.
Warning: if you don’t “Select All” before sorting, it may only sort one column. This
will get your data all out of whack‐ for example a “name” column will no longer
match up with their respective street addresses if only the names get sorted.

Autofill
There is an easy way in excel to create long numbered lists, lists of days of the week, months, dates, etc
without having to type them in ad nauseum. You fill in a few cells with the beginning of the list you want
and excel will figure out the rest for you.
1. Make sure your cells are formatted for the appropriate number or date category (see above,
formatting).
2. Type in three or four entries‐ for example if you want a simple numbered list type 1, 2, 3 in three
different cells, all in a row going down.
3. Then, select all the cells you just entered.
4. Put the cursor in the bottom right‐hand corner, exactly on the outline of the cell. It will
turn to a dark + sign.
5. Click, hold, and drag down to highlight as many cells as you want the formula entered into.
Let go. You should have your completed list entered into those cells.
6. If it didn’t work the way you wanted, play around with the values you entered yourself‐
maybe give it more cells as example, and make sure they’re formatted correctly.
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Formulas

Excel can automatically make calculations for you if you tell it which cells you want to add, multiply, etc.
You do this by entering a “formula”. The formula lives in a cell of its own, and it shows up as the
calculated value. If you double click into the cell, however, you will see the actual formula and can edit it.
Cells are referred to by column/row coordinates‐ cell A1, B8, etc. A formula to add these two cells is
A1+B8 (no spaces in formulas). To multiply, A1xB8.
To enter a formula:
1. Type an “=” sign.
2. Type the coordinates of the first cell you want to use, then type a
“+” (or – or / or *). It will highlight the cells you’ve entered.
3. Type the coordinates of the next cell you want to use.
4. Hit enter.
5. The cell will then show the result.
If you select the cell now it will still just show the number result. To get back in to edit the formula you
need to double click the cell. You can then type, move your cursor around inside it, etc.
To get back out of editing the formula you need to either hit return or escape. Don’t try to get out by
clicking the mouse somewhere else because:
You can select cells to include in formulas by clicking on them, rather than having to type in the
coordinates. For example, if you want to enter the formula above, you can simple type “=”, click cell A1,
type +, and click cell B8. It will automatically enter the A1 and B8 for you. The trick is that if you are
simply trying to get out of the cell to work somewhere else, clicking won’t help‐ it will jut add the cells
you’re clicking into the formula.
Autosum
To add up a lot of cells the simplest thing to do is use the AutoSum feature. This takes a range of cells you
select and adds them all together automatically.
1. Select a blank cell where you want the result to appear.
2. Click the autosum button on your toolbar (it looks kind of like a big “E”).
3. Excel will guess at the cells you want to add and you’ll see them highlighted. If it
guessed wrong, simply select the cells you want to include (click, drag to highlight,
and let go). You’ll see the formula appear as “=SUM(C2:C5)” for example.
4. Hit return to exit the formula and see your result.
If things go wrong and your formula gets wacky, or you get an error message in the
formula cell, just hit escape to get out of editing the formula, clear the cell, and try again.
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Sheets
An excel workbook can contain multiple worksheets. This is useful if you have
several worksheets that all relate to the same thing‐ why not just keep them
together as one file?
You can switch between worksheets by clicking the tabs at the bottom of the
window. You can also right‐click on these tabs for a range of options‐ creating,
copying, moving, etc. You can re‐order the worksheets by dragging and
dropping the tabs.

Hyperlinks

If you type in a web or email address Excel will automatically make it into a “hyperlink” – ie if you click on
the link it will automatically open a web browser or email program and try to take you to the web
address. This can be annoying for a couple reasons‐ it formats the link blue and underlined which may
not match the rest of your sheet, and you may accidentally click the link just while working in the
spreadsheet. To remove the hyperlink and revert it back to regular text you can do the following:
• If you catch the hyperlink right after it’s created you will see a small autocorrect icon right by the
cell. Click on it and you’ll get a menu of options, one of which is to remove the link.
• If you want to permanently disable this feature, go to the Excel Menu > Preferences > Autocorrect,
and uncheck “Replace internet paths with hyperlinks”.
• Select the cell (careful not to click on the link), Right Click > Hyperlink… > Remove Hyperlink
button is on the bottom left.

Find/replace
To find a certain cell or cells, Edit Menu > Find.
• You can choose to search the whole workbook or just the current
worksheet.
• You can choose to search only for entries matching the case your enter
(ie find Smith but not smith).
• You can look for entire cells only (ie find Smith but not Pete Smith).
• You can also click the replace button if you want to make a bunch of replacements at a time‐ for
instance you can set it to replace all occurrences of “Smith” with “Smythe”.
Note: If you have cells selected at the time you run the Find feature, it will only search the selected cells,
ignoring the rest of the worksheet.
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Page setup
This is where you choose what you want your page to look like when printed. File Menu > Page Setup.
Page tab: choose vertical or horizontal orientation, and if you want your worksheet shrunk down or
enlarged for printing.
Options… button: Paper Size (letter, legal) and orientation.
Margins: How much blank space you want left around the data. Adjust as needed, just don’t go too close
to the edge of the paper or it might get cut off.
Header/Footer: If you want text to appear at the top or bottom of every page you print, enter it here.
Sheet: Here you can choose specific rows or columns that you want to print at the top of every page
(good if you have a header row), if you want to print the gridlines or not, if you want to print the row and
column headings (ie the numbers and letters).

Printing‐

File > Print. You’ll get a little preview of what your printed file will look like.
You can also click the PDF button on the lower left to save it as a PDF. Excel sometimes likes to print
blank pages, so check how many pages it’s going to print and adjust if necessary. You also have options to
just print the cells you have selected, or the entire workbook.
Print Area
If you know you only want to print a specific section of your worksheet, highlight those cells and choose
File Menu > Print Area > Set Print Area. Then it will only print what you have selected. If you want to
change your mind and print something else, choose File Menu > Print Area > Clear Print Area. This will
take you back to being able to print the whole worksheet.

Saving

File > Save. This will save your work. If you haven’t yet saved your workbook you should name it and
choose a location for it.
File > Save As. Do this if you want to create a copy of your workbook. You also have the option to change
its name and save to a new location. Once you do this you will be working on the NEW version of the
workbook, and the old version will remain untouched.
When saving, we recommend saving files down so that the older versions of excel can open them. In the
Save window, choose .xls format from the Format drop‐down menu. The default for the new 2008 version
of Excel is .xlsx, and while this is fine most of the time someone using the 2004 version of office won’t be
able to open it.

For More Help:
Microsoft’s Office Help Pages‐ Step‐by‐step instructions, videos, and courses on lots of Excel functions
and features.
http://www.microsoft.com/mac/help.mspx
Visit training.hampshire.edu for online tips & tutorials.
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