Form Software Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Survey Monkey</th>
<th>InFormEd</th>
<th>MS Word</th>
<th>Acrobat</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web Forms</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data Separation</td>
<td></td>
<td>✓</td>
<td>Limited</td>
<td>✓</td>
</tr>
<tr>
<td>Requires software purchase to fill form</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Freeform layout</td>
<td></td>
<td>✓</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Dynamic (growing) text fields</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Supports authentication (logging in)</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Free or covered by our sw licenses</td>
<td></td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Automatic Calculations</td>
<td></td>
<td></td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Signature Authentication</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Skip Logic</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data Validation</td>
<td>✓</td>
<td>Limited</td>
<td></td>
<td>✓</td>
</tr>
</tbody>
</table>

Form Options

<table>
<thead>
<tr>
<th>Product</th>
<th>Strengths</th>
<th>Weaknesses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Survey Monkey</td>
<td>• Web based forms&lt;br&gt;• Easy creation&lt;br&gt;• Separates data from form&lt;br&gt;• Easy data analysis tools&lt;br&gt;• No user authentication</td>
<td>• Costs money for &gt;100 survey responses&lt;br&gt;• Layout/flow limited&lt;br&gt;• Download of data requires paid account</td>
</tr>
<tr>
<td>InFormEd</td>
<td>• Separates data from form&lt;br&gt;• Free&lt;br&gt;• Can target on campus only, or wider audience&lt;br&gt;• Can authenticate users&lt;br&gt;• On-site tech support!</td>
<td>• Not overly flexible in layout</td>
</tr>
<tr>
<td>Word</td>
<td>• Easy to create&lt;br&gt;• Flexible layout&lt;br&gt;• Great dynamic text fields for printing</td>
<td>• No spell-checking in text fields&lt;br&gt;• Requires user have Word&lt;br&gt;• Limited data separation</td>
</tr>
<tr>
<td>Acrobat</td>
<td>• Flexile layout&lt;br&gt;• Very extensible&lt;br&gt;• Separates data from form&lt;br&gt;• Several data collection options&lt;br&gt;• Can be filled out with free Reader&lt;br&gt;• Spell check text fields</td>
<td>• Very complex program&lt;br&gt;• Doesn’t print dynamically sized text fields&lt;br&gt;• Layout is difficult to change&lt;br&gt;• Most editing should be done before bringing in to Acrobat</td>
</tr>
</tbody>
</table>
Using Microsoft Word 2007/2010 (PC) for Forms

Creating a Form
In order to user forms you must enable the Developer Tab:

1. From the B or File Menu select Word Options
2. Select Popular from the left pane, then check Show Developer Tab in the Ribbon.

Next, you create the basic document layout & add form fields:

1. Start with a new Word document, or open an existing template.
2. Save it as a template: Office button→Save As/Word Template.
3. Layout the entry prompts on your document, such as “Name: “ and “Telephone: “
4. Click where you want the form field to be placed. For instance, you may to insert a text field next to “Name: “.
5. From the Developer tab, select the control you want to insert. If you don’t see the particular control you want, look under “Legacy Tools.”

Now, edit the controls you just created:

1. In the Developer tab, Controls group, click Design Mode.
2. Click and edit the text in each Content Control.
3. If you have controls that need more information you can add it by selecting “Properties.” You will have to do this to create a list of values in combo box or drop-down list.

Before sending the document out to people to fill out, you must protect it:

1. On the Developer tab toggle Design Mode off.
2. On the Developer tab, in the Protect group, click Protect Document. This opens a Restrictions pane on the right side of the Word window.
3. Under Editing restrictions, check Allow only... then choose” Filling in forms” from the list.
4. Click “Yes, Start Enforcing Protection.” You will be prompted for a password to keep others from editing the form.
5. Save and close the file.

It’s good practice to test the form before you send it out:

1. Select Office Button→New... and select the template for your form. Test out entering the data.
2. If you need to make changes you must open the original template file, Stop Protection, and then edit. Make sure you turn Protection back on before saving & retesting.

Retrieving Data from your Form
If you only have a few forms you may opt to review them as is in Word. However, you may also want to pull data out of the form without the text of the form. This only works with Legacy fields. To create a comma-delimited file from a filled-out form:

1. From Office Button→Word Options/Advanced/Preserve fidelity with this document, select “Save form data as delimited text.”
2. Save the file & it will create a comma-delimited file.
Using Microsoft Word 2008 (Mac) for Forms

Creating a Form
First, create the document layout.

1. Start with a new Word document, or open an existing template.
2. Save it as a template: File→Save As/Word Template.
3. Layout the entry prompts on your document, such as “Name: “ and “Telephone: “

Now you add your form fields:

1. Get the Forms toolbar by selecting View→Toolbars→Forms
2. Click where you want the form field to be placed. For example, you may want to insert a text field next to “Name: “.
3. From the Developer tab, click on the control you want to insert.

Now, edit the controls you just created:

1. Select the control that you want to edit
2. Click on the “Form Field Options” icon on the Forms Toolbar. “Properties.” You will have to do this to create a list of values in drop-down list.

Before sending the document out to people to fill out, you must protect it:

2. You may want to add a password by going to Word→Preferences/Security and selecting “Protect Document…”
3. Save and close the file.

It’s good practice to test the form before you send it out:

1. Select Office Button→New… and select the template for your form. The document that opens will be based on that template but will have the name “Document1” or something similar.
2. Test out entering the data.
3. If you need to make changes you must open the original template file, turn off Protection, and then edit. Make sure you turn Protection back on before saving & retesting.

Retrieving Data from your Form
If you only have a few forms you may opt to review them as is in Word. However, you may also want to pull data out of the form without the text of the form. To create a comma-delimited file from a filled-out form:

1. From File→Preferences/Save select “Save data only for forms (for current document only)”
2. Save the file & it will create a comma-delimited file.
Using Microsoft Word 2011 (Mac) for Forms

Creating a Form

In order to use forms you must enable the Developer Tab; this is a one-time action:

1. From the Word Menu select Preferences...
2. Select “Ribbon.”
3. On the right, scroll down under “Print Layout View” and check the box next to “Developer.”

Create the document layout.

1. Start with a new Word document, or open an existing template.
2. Save it as a template: File→Save As/Word Template.
3. Layout the entry prompts on your document, such as “Name: “ and “Telephone: “

Now you add your form fields:

1. Select the Developer tab from the Ribbon.
2. Click where you want the form field. For example, you may want to insert a text field next to “Name: “.
3. From the Developer tab, click on the control you want to insert.

Now, edit the controls you just created:

1. Select the control that you want to edit
2. Click on the “Options” icon on the Developer Tab. “Properties.” You will have to do this to create a list of values in drop-down list.

Before sending the document out to people to fill out, you must protect it:

1. On the Developer Tab click Protect Form.
2. You may want to add a password by going to Word→Preferences/Security and selecting “Protect Document...”
3. Save and close the file.

It’s good practice to test the form before you send it out:

1. Select Office Button→New from Template... and select the template for your form. The document that opens will be based on that template but will have the name “Document1” or something similar.
2. Test out entering the data.
3. If you need to make changes you must open the original template file, turn off Protection, and then edit. Make sure you turn Protection back on before saving & retesting.

Retrieving Data from your Form

If you only have a few forms you may opt to review them as-is in Word. However, you may also want to pull data out of the form without the text of the form. To create a comma-delimited file from a filled-out form:

1. From File→Preferences/Save select Options and then check “Save data only for forms (for current document only)”
2. Save the file & it will create a comma-delimited file.
Using InFormEd (Hampshire Form Generator) for Forms

InFormEd is a form generator developed at Hampshire. There are full instructions online at https://intranet.hampshire.edu/forms/newFormsManual.pdf, which I suggest you read before starting a form. Here are some highlights to get you started.

Form Fields in InFormEd

*Horizontal Line*
A horizontal separator that extends across the page

*Text*
Displays text. Useful for instructions, wrap up.

*Input Text*
A single line of input to fill in.

<table>
<thead>
<tr>
<th>Super Test Form</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. What is your name?</td>
</tr>
</tbody>
</table>

*Input Text Area*
An input area that accepts multiple lines of input.

<table>
<thead>
<tr>
<th>Super Test Form</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Extra Credit: List the Gold Medals won by Phelps in the 2008 Beijing Olympics, in chronological order. The first and last ones have been done for you.</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

*Horizontal Radio*
A set of radio buttons positioned horizontally from one another. Only one button can be selected.

<table>
<thead>
<tr>
<th>Super Test Form</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Who discovered America in 1492?</td>
</tr>
</tbody>
</table>
**Vertical Radio**

A set of radio buttons positioned vertically. Only one button can be selected.

**Super Test Form**

1. Consider a race between John, Kelly, Adam, and Julie. If John finished the race ahead of Julie, Kelly finished behind Adam, Julie finished behind Kelly, and Adam finished behind John, what is the order of their finishes first, second, third, last?
   - John, Adam, Julie, Kelly
   - John, Julie, Kelly, Adam
   - Kelly, Adam, Julie, John
   - Kelly, Julie, Adam, John

---

**Horizontal Check Boxes**

A set of checkboxes positioned horizontally. Any number of them can be selected.

**Super Test Form**

1. What toppings do you prefer on pizza?
   - [ ] cheese
   - [ ] pepperoni
   - [ ] canadian bacon
   - [ ] sausage
   - [ ] chicken
   - [ ] mushrooms
   - [ ] green peppers
   - [ ] olives
   - [ ] anchovies
   - [ ] pineapples

---

**Selection List**

A drop-down selector that allows only one selection.

**Selection List Tests**

1. What size of drive would you like to purchase?
   - [ ] Largest
   - [ ] Smallest
   - [ ] Cheapest
   - [ ] < 1 GB
   - [ ] 1-10 GB
   - [ ] 10-100 GB
   - [ ] 100-500 GB
   - [ ] 500-1,000 GB
   - [ ] > 1,000 GB

---

**Vertical Check Boxes**

A set of checkboxes positioned. Any number can be selected.

**Super Test Form**

1. Which of the following would you like to subscribe to?
   - [ ] Time
   - [ ] People
   - [ ] Cosmopolitan
   - [ ] Wall Street Journal
   - [ ] New Yorker
**Columned Questions**

A table with a series of questions along the left hand side and a series of answers along the top, with either checkboxes or radio buttons inside the table.

<table>
<thead>
<tr>
<th>Super Test Form</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Here at Pepsi-Co, we want to know about your tastes. Please rate the following soft-drink beverage soda pops on a range of 1-5, with 5 being the highest.</td>
</tr>
</tbody>
</table>
| ![Table of ratings](image)

<table>
<thead>
<tr>
<th>Super Test Form</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Please indicate which seminars you are pre-registering for and for which date(s). Note that the seminar “How to Become a Cult Leader” is required at least once for all attendees.</td>
</tr>
</tbody>
</table>
| ![Table of seminars](image)

**Retrieving Data from InFormEd**

There are several options for receiving the responses to your form.

- Have the responses emailed to you. This is a good choice if you have a form that has a long life & you’ll be receiving infrequent responses—you don’t have to remember to check for responses.
- Look at the responses online in HTML format. This is a good choice if you only have a few responses coming in. It will allow you to review them one by one.
- Download Tab-Delimited. This will create a file you can open in Excel, allowing you to manipulate the data there.

**A Couple of Gotchas**

Things to remember when using InFormEd:

- Enable your form before pointing users to it.
- Always save your changes before returning to the main forms page.